2018-04-25

Q&A:突然「Warning: Parameter 1 to wp_default_scripts() expected to be a reference XXX」のようなエラー表示がサイトにでるようにりました。

レンタルサーバーの設定(PHPやMySQLのバージョン)を変更した直後や、WordPress本体バージョンアップした直後などに、

Warning: Parameter 1 to multibyte_patch::wplink_js() expected to be a reference, value given in /XXXX.php on line xxx
Warning: Parameter 1 to wp_default_scripts() expected to be a reference, value given in /XXXX.php on line xxx
Warning: Parameter 1 to wp_default_styles() expected to be a reference, value given in /XXXX.php on line xxx

みたいなエラーがサイト上に表示されることがあります。

これはご利用のWordPressのバージョンとサーバーの環境が合っていないことが原因です。
ご利用のサーバーがWordPressの推奨動作環境を満たしているか、ちゃんと確認してください。
古いバージョンのWordPressを使い続けていて、サーバーを最新にした時などに起こりやすいです。

この手のエラー表示が出た場合は、動作環境を見直して正しい組み合わせに変更してください。
動作環境を正しく戻せばエラーは消えます。

*サーバーの操作方法に関しては、レンタルサーバー会社・サーバー管理者にお問い合わせ下さい。

その他のWordPressのよくある質問

WordPressのトラブル・よくある質問の一覧を見てみる >

トラブルが少ないシンプルなWordPressテーマ

Minimal WPのシンプルでおしゃれなWordPressテンプレートは、
余計な機能や設定を徹底的に排除したミニマル仕様。
トラブルも少なく、初心者でも簡単に安心して使えます。

WordPressテンプレートのデザイン一覧を見てみる >

by
おすすめWordPressテーマ10選